k3s 基于 docker 运行时,如果 docker 自身存在容器在跑。 k3s 清理镜像调度就会失败。
调整清理阈值
/etc/rancher/k3s/config.yaml
增加以下内容
kubelet-arg:
- "eviction-hard=nodefs.available<3%,imagefs.available<2%"
- "eviction-soft=nodefs.available<3%,imagefs.available<2%"
- "eviction-soft-grace-period=nodefs.available=1m"
- "eviction-soft-grace-period=imagefs.available=1m"
手动清理 docker 存储
评论栏
分享你的想法,或参与下面的讨论。
参与讨论
支持 Markdown、代码和图片
友善交流,让讨论更有价值。
更多留言
加载中…